Debian / IPv6: Il path predefinito scade dopo 1800 secondi, perdendo la connettività

Sto eseguendo Debian 8 su un server vServer. Dopo l'installazione del docker e l'abilitazione di IPv6 ho notato qualcosa di strano. Non so se il docker ha qualcosa a che fare con questo, è solo che ho notato questo problema dopo averlo installato.

Il mio path predefinito è configurato per scadere dopo ca. 1800secs. In realtà scompare dopo questo timeout. Questo è quando io (ovviamente) la connessione di IPv6 allentata.

  • Se gli IP pubblici sono collegati ad un solo AS, come funziona il BGP anycast?
  • Ha bisogno di una zona di ricerca inversa IPv6 per una networking Active Directory?
  • Utilizzo del servizio DHCP di Windows Server 2003 per fornire un router diverso a host specifici
  • Perché questo preseed per il guitolo fallisce?
  • VirtualBox: come configurare la networking in modo che sia host che guest possono accedere a Internet e parlare tra di loro
  • Perché alcuni interruttori di networking smettono di funzionare, altri sono bene?
  • root@wopr:~# ip -6 route xxxx:yyyy:zzz:xxxx::/64 dev eth0 proto kernel metric 256 fe80::/64 dev eth0 proto kernel metric 256 fe80::/64 dev br-5c1ce68ea951 proto kernel metric 256 fe80::/64 dev br-61f6bbfdbe87 proto kernel metric 256 [a lot more routed for my docker containers] default via fe80::1 dev eth0 proto ra metric 1024 expires 1259sec hoplimit 64 

    Perché la routine è configurata per scadere dopo 1800 s? Dove posso configurare questo?

    [modifica 2016-05-14 16:08]

    L'aggiunta manuale di un path di default sembra funzionare bene. Rimane messo. Ma ho bisogno di avere un path non scaduto dopo l'avvio.

    [modifica 2016-05-14 16:13]

    La macchina è in esecuzione su un host KVM ospitato da netcup.de. Sta utilizzando il driver virtio, come raccomandato dal mio fornitore.

     root@wopr:~# cat /etc/network/interfaces auto lo iface lo inet loopback iface lo inet6 loopback auto eth0 iface eth0 inet dhcp iface eth0 inet6 static address xxxx:yyyy:zzz:xxxx::1 netmask 64 gateway fe80::1 

    virt-cosa dice:

     root@wopr:~# virt-what kvm 

    [modifica 2016-05-14 15:34] Sembra che mi sia mancato che net.ipv6.conf.default.autoconf fosse impostato su 1. Ora ho aggiunto un file in /etc/sysctl.d per sopprimere questo durante l'avvio:

     root@wopr:~# cat /etc/sysctl.d/ipv6.conf net.ipv6.conf.default.accept_ra=0 net.ipv6.conf.default.autoconf=0 net.ipv6.conf.all.accept_ra=0 net.ipv6.conf.all.autoconf=0 net.ipv6.conf.eth0.accept_ra=0 net.ipv6.conf.eth0.autoconf=0 

  • Determinare la versione OS di una casella OEL linux?
  • Come aprire la port 555 in Linux / Debian
  • Come montare un secondo disco rigido? Debian
  • Come faccio a sapere se la mia casella Linux è stata infiltrata?
  • Qualcun altro che si riscontra un alto numero di server Linux si blocca durante un secondo giorno di salto?
  • Qual è il modo "debian" di installare più istanze mysql su un singolo server?
  • 2 Solutions collect form web for “Debian / IPv6: Il path predefinito scade dopo 1800 secondi, perdendo la connettività”

    Sembra che mi sia mancato che net.ipv6.conf.default.autoconf fosse impostato su 1. Aggiunta di un file in /etc/sysctl.d per sopprimere questo problema all'avvio ha risolto il problema per me:

     root@wopr:~# cat /etc/sysctl.d/ipv6.conf net.ipv6.conf.default.accept_ra=0 net.ipv6.conf.default.autoconf=0 net.ipv6.conf.all.accept_ra=0 net.ipv6.conf.all.autoconf=0 net.ipv6.conf.eth0.accept_ra=0 net.ipv6.conf.eth0.autoconf=0 

    Ora ho un path predefinito che non scadrà all'avvio. Problema risolto. Grazie per aver indicato la giusta direzione, Sander.

    1800 secondi suona come un timeout predefinito per un router pubblicitario.

    La mia prima ipotesi sarebbe che ci sia un router Cisco sulla networking che è configurato con ipv6 nd ra suppress l'interface. In questa modalità il router invierà un RA quando un host richiede una RS, ma non lo aggiorna regolarmente. Un host invia una RS quando viene portto l'interface, il che spiegherebbe perché viene avviato un path predefinito dopo l'avvio.

    Quella impostazione è una strana impostazione inutile di Cisco. Un router dovrebbe submit RA quando viene richiesto + regolarmente (il default su Cisco), o no ( ipv6 nd ra suppress all ). L'impostazione a metà ipv6 nd ra suppress causa un comportmento strano come questo e non deve essere utilizzato.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.