Le dependencies rotte su CentOS 6.4: possono installare nodejs ma non npm

Sto utilizzando un nuovo CentOS 6.4 installato (x86-64) con il repository EPEL.

$ yum install nodejs ... $ node -v v0.10.5 

Finora, così buono, ma quando provo a installare npm , npm questo messaggio di errore:

  • Come accedere a MySQL su CentOS 6.3 utilizzando l'account root dal dominio e non localhost?
  • Allocata 4GB di RAM a VM ma Linux mostra solo circa 3GB di memory totale
  • Installazione fresca di RHEL 6.1 - yum che non si aggiorna
  • richiesta non rioutput: errore di lettura delle intestazioni
  • Installare msttcorefonts su CentOS 6.3
  • agetty è costantemente terminato
  •  $ yum install npm Loaded plugins: fastestmirror, refresh-packagekit, security Loading mirror speeds from cached hostfile * base: ftp.halifax.rwth-aachen.de * epel: mirror.fraunhofer.de * extras: centos.psw.net * updates: centos.psw.net Setting up Install Process Resolving Dependencies --> Running transaction check ---> Package npm.noarch 0:1.2.17-5.el6 will be installed --> Processing Dependency: npm(which) < 2 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(uid-number) < 1 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(tar) < 0.2 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(slide) < 2 for package: npm-1.2.17-5.el6.noarch --> Processing Dependency: npm(semver) < 1.2 for package: npm-1.2.17-5.el6.noarch ... (skipped) ... --> Finished Dependency Resolution Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (epel) Requires: npm(ansi) < 0.2 Error: Package: npm-1.2.17-5.el6.noarch (epel) Requires: npm(ansi) < 0.2 Error: Package: nodejs-npmlog-0.0.2-4.el6.noarch (epel) Requires: npm(ansi) >= 0.1.2 Error: Package: npm-1.2.17-5.el6.noarch (epel) Requires: npm(ansi) >= 0.1.2 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodesgest 

    L'output completo è piuttosto grande: http://pastebin.com/raw.php?i=Ce3ZJsEB

    Cosa dovrei fare? La soluzione alternativa --skip-broken non sembra essere la soluzione giusta.

    Ecco la produzione di yum repolist :

     Loaded plugins: fastestmirror, refresh-packagekit, security Determining fastest mirrors * base: centos.copahost.com * epel: mirror.fraunhofer.de * extras: ftp-stud.fht-esslingen.de * updates: centos.copahost.com repo id repo name status base CentOS-6 - Base 6,381 epel Extra Packages for Enterprise Linux 6 - x86_64 8,909 extras CentOS-6 - Extras 12 updates CentOS-6 - Updates 727 repolist: 16,029 

  • Quali applicazioni possono essere utilizzate in un cluster Red Hat / CentOS?
  • Il funzionamento di errore CentOS - resize2fs non è consentito mentre si tenta di aggiungere il gruppo #
  • Filtrare il traffico in arrivo alla port UDP per la conformità del PCI
  • Configrue Exim Sendmail per il relay
  • Timesync su HyperV con CentOS 6.2
  • Come eseguire la scansione di virus Windows sui server Linux?
  • One Solution collect form web for “Le dependencies rotte su CentOS 6.4: possono installare nodejs ma non npm”

    Il pacchetto nodejs-ansi da EPEL ( nodejs-ansi-0.1.2-7.el6.noarch ) è interrotto.

    Provare:

     wget http://kojipkgs.fedoraproject.org//packages/nodejs-ansi/0.1.2/7.el6.1/noarch/nodejs-ansi-0.1.2-7.el6.1.noarch.rpm yum --enablerepo="epel" install npm ./nodejs-ansi-0.1.2-7.el6.1.noarch.rpm 

    Soluzione fondata su #epel all'indirizzo irc.freenode.net.

    Vedi anche: http://pastebin.com/mqFqRqUp linea 28

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.