Perché Ubuntu Server 9.04 non sarà aggiornato a 9.10?

Ho un server in esecuzione 9.04 e vorrei aggiornarlo a 9.10 (sulla strada per arrivare alla versione più recente). Tuttavia, nonostante la bella documentazione , non posso.

In particolare, l' sudo do-release-upgrade non riesce:

  • Aggiornare in modo sicuro php 5.3.3 a> = 5.3.4 su centos 6
  • Come faccio a / dev / random per lavorare su una macchina virtuale Ubuntu?
  • Condivisione networking di networking
  • DynDNS e server di posta
  • chmod -R 777 sul server PXE - perché
  • Come faccio a smettere di installare Ubuntu daemoni che non ho esplicitamente chiesto di eseguire?
  •  Checking for a new ubuntu release Done Upgrade tool signature Done Upgrade tool Done downloading extracting 'lucid.tar.gz' authenticate 'lucid.tar.gz' against 'lucid.tar.gz.gpg' tar: Removing leading `/' from member names Reading cache Checking package manager Can not upgrade An upgrade from 'jaunty' to 'lucid' is not supported with this tool. 

    Il mio /etc/apt/sources.list originale:

     ## EOL upgrade sources.list # Required deb http://old-releases.ubuntu.com/ubuntu/ jaunty main restricted universe multiverse deb http://old-releases.ubuntu.com/ubuntu/ jaunty-updates main restricted universe multiverse deb http://old-releases.ubuntu.com/ubuntu/ jaunty-security main restricted universe multiverse # Optional #deb http://old-releases.ubuntu.com/ubuntu/ jaunty-backports main restricted universe multiverse #deb http://old-releases.ubuntu.com/ubuntu/ jaunty-proposed main restricted universe multiverse 

    Cambiare le old-releases di karmic e old-releases releases dà 404 errori quando sudo aptitude update . E, il sudo do-release-upgrade tenta ancora di aggiornare direttamente in shiny.

  • Come aggiornare Adobe Flash dalla row di command?
  • I rapporti di rkhunter cambiano nelle properties; di file, ma non vedo che sono state aggiornate da yum
  • Installazione remota WSUS Aggiornamento aggiornato Installazione
  • Openssl aggiornamento dalla fonte
  • quanto spesso devo installare gli aggiornamenti sul server Windows 2008 R2?
  • WSUS e Patches estratti
  • 3 Solutions collect form web for “Perché Ubuntu Server 9.04 non sarà aggiornato a 9.10?”

    Probabilmente troppo tardi ma ….

    Cambiare le versioni a karmiche e vecchie versioni per rilasciare dà 404 errori

    Questo dovrebbe essere vecchie versioni per archiviare

    Questo aggiornamento non funziona affatto!
    Dalla mailing list di ubuntu-security-announce (ricevuta la scorsa settimana):

     This note is just to confirm that the support period for Ubuntu 9.10 (Karmic Koala) formally ended on May 1, 2011 and Ubuntu Security Notices no longer includes information or updated packages for Ubuntu 9.10. 

    Quindi i 404.
    "Soluzione cruciale": sostituire tutti i "jaunty" in /etc/apt/sources.list e /apt/sources.list.d/* con "lucid" e eseguire "aptitude update & & aptitude dist-upgrade"

    Vedo do-release-upgrade automaticamente l'aggiornamento a Lucid, che è sbagliato (forse un bug, in quanto i documenti non indicano questa possibilità).

    Controllare /etc/update-manager/release-upgrades . Dice Prompt=lts ? In caso affermativo, provate a cambiarlo in Prompt=normal .

    Se tutto non riesce a provare ad aggiornare il modo Debian – modificando le tue origini per puntare a Karmic e facendo apt-get update && apt-get dist-upgrade .

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.