PHP è rotto dopo l'aggiornamento a php 5.4

su un ubuntu 12.04 ho aggiornato a PHP 5.4 in base a questo tutorial http://www.upubuntu.com/2012/03/how-to-upgrade-install-php-540-under.html Ma quando chiamo php5 -v ottengo

 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/mysql.so' - /usr/lib/php5/20100525/mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/mysqli.so' - /usr/lib/php5/20100525/mysqli.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib/php5/20100525/pdo_mysql.so' - /usr/lib/php5/20100525/pdo_mysql.so: cannot open shared object file: No such file or directory in Unknown on line 0 PHP 5.4.0-3~lucid+4 (cli) (built: Mar 27 2012 08:55:12) Copyright (c) 1997-2012 The PHP Group Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies 

come posso risolvere il problema senza rompere altre cose? 😉

  • Utilizzare una NIC per creare più interfacce per Linux KVM
  • Debian dist-upgrade non interattivo al 100%
  • Specificare un path preferito quando ci sono più collegamenti alla stessa networking
  • Linux controlla l'elaborazione delle email in diretta
  • Impostare il limite dei file aperti in Linux per utente. Imansible impostare più di 1024
  • Come visualizzare i dispositivi utilizzati / spazio libero quando si utilizza LVM?
  • modificare, quando si tenta di installare php5-mysql

     sudo apt-get install php5-mysql 

    ottengo

     Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation: The following packages have unmet dependencies: php5-mysql : Depends: libmysqlclient16 (>= 5.1.21-1) but it is not installable E: Unable to correct problems, you have held broken packages. 

    5 Solutions collect form web for “PHP è rotto dopo l'aggiornamento a php 5.4”

    L'installazione di nuove versioni PHP sulle macchine Ubuntu che non li support non è consigliata.

    Se è veramente necessario, prova a installare i pacchetti PHP e MySQL da DotDeb, che ha anche tutte le estensioni. Istruzioni sul loro sito web http://www.dotdeb.org/instructions/

    Se l'installazione chiede nuove versioni dei tuoi libs, è ansible scaricarli da http://packages.debian.org e installarli manualmente utilizzando dpkg -i packagename.deb .

    Notare che questo può rovinare l'installazione di Ubuntu. Prova questo su una macchina virtuale o un ambiente recuperabile, mai in produzione.

    Hai provato a riavviare il tuo webserver?

     sudo /etc/init.d/apache2 restart 

    Non hanno usato Ubuntu in un po ', ma credo che sia quello

    e poi dopo aver provato a installare i pacchetti in questione. Quelli MySQL

    Ubuntu 12.4 è ancora beta fase (beta finale) per quanto ne so. Dal momento che libmysqlclient16 è stato rimosso da repubblica Ubuntu 12.04, sarà necessario installarlo manualmente. Download pacchetti: versione a 32 bit – http://launchpadlibrarian.net/94563300/libmysqlclient16_5.1.58-1ubuntu5_i386.deb versione a 64 bit – http://launchpadlibrarian.net/94808408/libmysqlclient16_5.1.58-1ubuntu5_amd64.deb

    e quindi installarlo con: sudo dpkg -i libmysqlclient16_5.1.58-1ubuntu5_XXX.deb Probabilmente dovrai aggiornare il tuo server mysql a 5.1.58

    Ho questo problema anche su Debian Testing / Wheezy. Non ho idea del perché le estensioni siano installate in / usr / lib / php5 / 20100525 /, ma sembra che sia where sono. Per risolvere il problema, apri il tuo file php.ini ovunque tu possa essere (probabilmente in / etc / php * o qualcosa) e modifica / aggiungi la seguente row:

     extension_dir = "/usr/lib/php5/20100525/" 

    Quindi riavviare il tuo php5-fpm se sai come, o semplicemente riavvii la macchina e PHP dovrebbe funzionare di nuovo.

    Questo pacchetto è obsoleto per Debian versione 7. Quindi un'opzione è distriggersrla.

    1. andare a /etc/php5/conf.d/
    2. modificare /etc/php5/conf.d/mhash.ini
    3. distriggersre aggiungendo; la prossima linea come quella

       ;extension=mhash.so 

    Questa libreria si trova in /usr/lib/pyshared/python2.7 . Ho provato a colbind ( ln ) a questo ma non funziona perché mostrano un errore binario.

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.