Ripristino di PHP da 5,4 a 5,3 su CentOS 6.5?

Sto cercando di downgrade PHP da 5.5.8 a 5.3.x. Ho provato questo ma funziona per me.

yum downgrade php 

L'errore che ho avuto è

  • Come faccio a utilizzare RPM per installare GCC dal mio supporto di distribuzione CentOS?
  • Come build un disco driver per un'installazione anaconda (CentOS 6)
  • Nessun spazio rimasto sul dispositivo dopo la crescita del filesystem
  • Dispositivo / dev / sdb1 non trovato (o ignorato dal filter)
  • Controllare la connettività yum da uno script?
  • Apache su Windows in ambiente di produzione? Perchè no?
  •  Loaded plugins: fastestmirror, refresh-packagekit, security Setting up Downgrade Process Loading mirror speeds from cached hostfile * Webmin: webmin.mirror.somersettechsolutions.co.uk * base: centos.excellmedia.net * epel: epel.mirror.net.in * extras: centos.excellmedia.net * updates: centos.excellmedia.net No Match for available package: php-5.3.3-26.el6.x86_64 Nothing to do 

    Ho anche provato questo, ma anche questo lavoro di lavoro per me.

     sudo yum downgrade php php-common php-cli 

    Il registro degli errori che ho ottenuto è

      Loaded plugins: fastestmirror, refresh-packagekit, security Setting up Downgrade Process Loading mirror speeds from cached hostfile * Webmin: webmin.mirror.somersettechsolutions.co.uk * base: centos.excellmedia.net * epel: epel.mirror.net.in * extras: centos.excellmedia.net * updates: centos.excellmedia.net No Match for available package: php-5.3.3-26.el6.x86_64 Resolving Dependencies --> Running transaction check ---> Package php-cli.x86_64 0:5.3.3-27.el6_5 will be a downgrade ---> Package php-cli.x86_64 0:5.5.8-1.el6.remi will be erased ---> Package php-common.x86_64 0:5.3.3-27.el6_5 will be a downgrade ---> Package php-common.x86_64 0:5.5.8-1.el6.remi will be erased ---> Package php-pecl-zip.x86_64 0:1.12.4-1.el6.remi.5.5 will be obsoleted --> Finished Dependency Resolution Error: Package: php-pecl-memcached-2.1.0-7.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(api) = 20121113-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(api) = 20121113-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Error: Package: php-process-5.5.8-1.el6.remi.x86_64 (@remi-php55) Requires: php-common(x86-64) = 5.5.8-1.el6.remi Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php-common(x86-64) = 5.5.8-1.el6.remi Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Error: Package: php-pecl-igbinary-1.1.2-0.5.git3b8ab7e.el6.remi.1.x86_64 (@remi-php55) Requires: php(zend-abi) = 20121212-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(zend-abi) = 20121212-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Error: Package: php-pecl-memcached-2.1.0-7.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(zend-abi) = 20121212-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(zend-abi) = 20121212-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Error: Package: php-pecl-mongo-1.4.5-1.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(zend-abi) = 20121212-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(zend-abi) = 20121212-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Error: Package: php-pecl-mongo-1.4.5-1.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(api) = 20121113-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(api) = 20121113-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Error: Package: php-pecl-igbinary-1.1.2-0.5.git3b8ab7e.el6.remi.1.x86_64 (@remi-php55) Requires: php(api) = 20121113-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(api) = 20121113-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Error: Package: php-gd-5.5.8-1.el6.remi.x86_64 (@remi-php55) Requires: php-common(x86-64) = 5.5.8-1.el6.remi Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php-common(x86-64) = 5.5.8-1.el6.remi Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Error: Package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(zend-abi) = 20121212-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(zend-abi) = 20121212-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Error: Package: php-pecl-memcache-3.0.8-1.el6.remi.1.x86_64 (@remi-php55) Requires: php(zend-abi) = 20121212-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(zend-abi) = 20121212-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Error: Package: php-pecl-apcu-4.0.3-1.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(zend-abi) = 20121212-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(zend-abi) = 20121212-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Error: Package: php-pecl-memcache-3.0.8-1.el6.remi.1.x86_64 (@remi-php55) Requires: php(api) = 20121113-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(api) = 20121113-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Error: Package: php-mbstring-5.5.8-1.el6.remi.x86_64 (@remi-php55) Requires: php-common(x86-64) = 5.5.8-1.el6.remi Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php-common(x86-64) = 5.5.8-1.el6.remi Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Error: Package: php-mcrypt-5.5.8-1.el6.remi.x86_64 (@remi-php55) Requires: php-common(x86-64) = 5.5.8-1.el6.remi Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php-common(x86-64) = 5.5.8-1.el6.remi Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Error: Package: php-pecl-jsonc-1.3.3-1.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(zend-abi) = 20121212-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(zend-abi) = 20121212-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(zend-abi) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(zend-abi) = 20090626 Error: Package: php-pecl-jsonc-1.3.3-1.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(api) = 20121113-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(api) = 20121113-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Error: Package: php-xml-5.5.8-1.el6.remi.x86_64 (@remi-php55) Requires: php-common(x86-64) = 5.5.8-1.el6.remi Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php-common(x86-64) = 5.5.8-1.el6.remi Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 Error: Package: php-pecl-apcu-4.0.3-1.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(api) = 20121113-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(api) = 20121113-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Error: Package: php-pecl-sqlite-2.0.0-0.4.svn332053.el6.remi.5.5.x86_64 (@remi-php55) Requires: php(api) = 20121113-64 Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php(api) = 20121113-64 Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php(api) = 20090626 Available: php-common-5.3.3-26.el6.x86_64 (base) php(api) = 20090626 Error: Package: php-pdo-5.5.8-1.el6.remi.x86_64 (@remi-php55) Requires: php-common(x86-64) = 5.5.8-1.el6.remi Removing: php-common-5.5.8-1.el6.remi.x86_64 (@remi-php55) php-common(x86-64) = 5.5.8-1.el6.remi Downgraded By: php-common-5.3.3-27.el6_5.x86_64 (updates) php-common(x86-64) = 5.3.3-27.el6_5 Available: php-common-5.3.3-26.el6.x86_64 (base) php-common(x86-64) = 5.3.3-26.el6 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodesgest [root@centos1 /]# php -v PHP 5.5.8 (cli) (built: Jan 9 2014 08:14:44) Copyright (c) 1997-2013 The PHP Group Zend Engine v2.5.0, Copyright (c) 1998-2013 Zend Technologies 

    Per favore aiutathemes.

  • Apache Non funziona mai dopo aver configurato eAccelerator e FastCGI
  • Ci sono problemi che migrano da RHEL a CentOS?
  • Apache: Come passare all'API CGI / FastCGI Server?
  • Problemi di Webserver Gestore PHP per IIS
  • Come puoi installare il burattino su CentOS 7?
  • Quali suggerimenti di sicurezza per il mio primo server? (completo completo)
  • One Solution collect form web for “Ripristino di PHP da 5,4 a 5,3 su CentOS 6.5?”

    Sembra che hai installato un sacco di moduli PHP aggiuntivi da remi repository. Quando si declina PHP, le dependencies non sono più disponibili. Potresti anche cercare di ridimensionarli

     yum downgrade php* 

    Ma questo probabilmente fallirà anche perché non tutti questi pacchetti sono disponibili nei repository standard

    Suggerisco di rimuovere tutti i pacchetti PHP innanzitutto:

     yum remove php* 

    Successivamente, è ansible reinstallare i pacchetti necessari dal repo standard:

     yum install php php-cli ... 
    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.