Tag: apt

Gestione del pacchetto su Mac OS X

Può qualcuno consigliare uno strumento di gestione dei pacchetti come apt-get o yum per Mac OS X? Ho visto che Fink ha portto apt-get a Mac OS X, è questo un buon modo per andare, o ci sono altre opzioni migliori?

Quanto sono protetti i mirror di repository di terze parti Ubuntu (APT)

Usiamo gli specchi locali di repository di Ubuntu, perché il nostro traffico esterno non è gratuito. Ogni volta che faccio apt-get install "program" ottiene da quel repository. La domanda è … possono i sostenitori del repository sostituire qualsiasi pacchetto sul repository con il proprio pacchetto? Posso essere facilmente attaccato su qualsiasi apt-get upgrade apt-get install […]

dpkg rotto durante l'aggiornamento di Debian Etch a Lenny

Buona giornata! Mentre cerco di recuperare una scatola a Lenny sembra che ho rotto le cose. Aggiorna libc e glib dopo che dpkg sembra essere rotto. Posso eseguire apt-get , ma ottiene la colpa di segmentazione da dpkg: # apt-get -f install Reading package lists… Done Building dependency tree… Done 0 upgraded, 0 newly installed, […]

Distriggersre il pacchetto virtuale nelle preferenze di / etc / apt / di Debian

So che posso distriggersre un particolare pacchetto in Debian aggiungendo /etc/apt/preferences con: Package: *x11* Pin: release Pin-Priority: -1 Ma come posso fare per un pacchetto virtuale come httpd ? Vorrei impedire l'installazione di tutti i pacchetti che forniscono questo httpd virtuale, ma quello selezionato da me. C'è un modo semplice per fare questo? Il motivo: […]

Imansible apt-get installare il pacchetto nginx-extras in cima a nginx 1.7.9

Sto tentando di installare Phusion Passenger per nginx su una dev Ubuntu box seguendo questa guida dal sito web del passeggero. Ho Nginx installato e già in esecuzione, la versione è 1.7.9-1 ~ fidata. Sto tentando di seguire il prerequisito: apt-get install nginx-extras e questo non riesce con il messaggio di errore: Unpacking nginx-common (1:1.6.2-2.4.0.56~trusty1) […]

Colbind l'installazione del pacchetto Debian

Quando si installa i pacchetti con i demoni, spesso riavviano tale servizio durante l'installazione / l'aggiornamento su Debian. Ho un demone che dispone di alcune opzioni che possono essere impostate solo su runtime, non configurate. Se il pacchetto Debian era sotto il mio controllo, cambierei l'init-script in modo da contenere una function per impostare quelle […]

Aggiornamento aggiornato bloccato da dependencies loopsche

Ho Debian in esecuzione su un'istanza VPS che viene mantenuta viva per un piccolo sito / progetto che viene utilizzato da una piccola base utente su base irregolare. Il server è in gran parte lasciato da sola ma cerco di accedere each tanto per mantenere i pacchetti aggiornati. Oggi ho capito che non ero stato […]

Firma del repository debian: Evitare l'aggiornamento di SHA1, apt-get e ancora lamentarsi di digerire debole

Conservo un piccolo deposito di debian per il mio datore di lavoro e siamo stati affrontati recentemente a causa della depreazione SHA1. Firmiamo i nostri pacchetti con un codice RSA 4096bit. Per la firma del repository, ho usato questo command GPG: root@name-not-revealed.com:/var/www/debian/dists/xenial# cat /root/.gnupg/gpg.conf cert-digest-algo SHA512 digest-algo SHA512 disable-cipher-algo SHA1 default-preference-list SHA512 SHA384 SHA256 SHA224 […]

upgrade glibc su RHEL4 senza rompere nulla

Ho una versione statica di wkhtmltopdf che richiede glibc-2.4 wkhtmltopdf: /lib/tls/libc.so.6: versione `GLIBC_2.4 'non trovata (richiesta da wkhtmltopdf) Ho installato con il repos DAG. A parte questo, il server è abbastanza standard di riserva tranne Coldfusion MX7. La mia domanda è, è sicuro di "apt update glibc" ? Lo glibc aggiornato sarà il vecchio o […]

Probelms Intstalling Trac che utilizza apt-get Ubuntu Jaunty

Sto avendo alcune difficoltà ad installare correttamente il tracciato sulla mia Ubuntu Jaunty Box. Utilizzando il command 'apt-get install trac' ho la seguente output: root@myserver:~# apt-get install trac Reading package lists… Done Building dependency tree Reading state information… Done Some packages could not be installed. This may mean that you have requested an impossible situation […]

Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.