Yum: conflitti di php55w-comuni con php-common-5.4

Sto cercando di installare mysqli su una macchina CentOS usando yum install php-mysqlnd.x86_64 sulla row di command, ma continuo a ricevere il messaggio:

 Error: php55w-common conflicts with php-common-5.4.16-36.el7_1.x86_64 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodesgest 

Nessuna delle soluzioni suggerite suggerisce nulla per aiutare il problema.

  • Ricarica my.cnf senza riavviare il servizio MySql
  • Quali sono i migliori strumenti di audit di sicurezza per le applicazioni web PHP?
  • installare il driver del server sql su ubuntu
  • modo consigliato per configurare un'interface di networking centos-7 con le impostazioni statiche tramite un messaggio
  • Collegamento simbolico al database mysql
  • Imansible installare la vernice su CentOS 7
  • Ecco il text completo visualizzato quando tento di installare:

    sudo yum install php-mysqlnd.x86_64 Loaded plugins: fastestmirror, replace Loading mirror speeds from cached hostfile * base: mirror.acsnet.com * extras: mirrors.chkhosting.com * rpmforge: mirror.webnx.com * updates: mirror.netdepot.com Resolving Dependencies --> Running transaction check ---> Package php-mysqlnd.x86_64 0:5.4.16-36.el7_1 will be installed --> Processing Dependency: php-pdo(x86-64) = 5.4.16-36.el7_1 for package: php-mysqlnd-5.4.16-36.el7_1.x86_64 --> Running transaction check ---> Package php-pdo.x86_64 0:5.4.16-36.el7_1 will be installed --> Processing Dependency: php-common(x86-64) = 5.4.16-36.el7_1 for package: php-pdo-5.4.16-36.el7_1.x86_64 --> Running transaction check ---> Package php-common.x86_64 0:5.4.16-36.el7_1 will be installed --> Processing Conflict: php55w-common-5.5.26-1.w7.x86_64 conflicts php-common < 5.5.0 --> Finished Dependency Resolution Error: php55w-common conflicts with php-common-5.4.16-36.el7_1.x86_64 You could try using --skip-broken to work around the problem You could try running: rpm -Va --nofiles --nodesgest

    Sembra che sta cercando di installare per php 5.4 invece di 5.5 che è la versione che sto cercando di installare per …

    Qualche idea su come posso installare mysqli e lavorare con php 5.5 su CentOs 7? Ho provato a seguire diverse guide, ma non posso superare le fasi di installazione a causa dei problemi di dipendenza.

    One Solution collect form web for “Yum: conflitti di php55w-comuni con php-common-5.4”

    Ho dovuto installare il rpms per php 5.5.

     rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm rpm -Uvh https://mirror.webtatic.com/yum/el7/webtatic-release.rpm 

    Quindi eseguire:

     sudo yum install php55w-mysqlnd.x86_64 

    Controllare doppio il file php.ini per assicurarsi che mysqli sia abilitato e riavviare il servizio httpd con sudo systemctl restart httpd.service .

    Dovrebbe farlo!

    Suggerimenti per Linux e Windows Server, quali Ubuntu, Centos, Apache, Nginx, Debian e argomenti di rete.